POJ-2236,Wireless Network

简介: POJ-2236,Wireless Network

Description:


An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.


In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.  


Input:


The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

1. "O p" (1 <= p <= N), which means repairing computer p.

2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.


The input will not exceed 300000 lines.  


Output:


For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.


Sample Input:


4 1


0 1


0 2


0 3


0 4


O 1


O 2


O 4


S 1 4


O 3


S 1 4  


Sample Output:


FAIL


SUCCESS


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,d,f[1001],vis[1001],x[1001],y[1001];
int getf(int v)
{
  if(f[v]==v)
    return v;
  else
  {
    f[v]=getf(f[v]);
    return f[v];
  }
}
void merge(int v,int u)
{
  int t1=getf(v);
  int t2=getf(u);
  if(t1!=t2)
    f[t2]=t1;
}
int dist(int a,int b)
{
  if(((x[a]-x[b])*(x[a]-x[b])+(y[a]-y[b])*(y[a]-y[b]))<=d*d)
    return 1;
  return 0;
}
int main()
{
  char s;
  scanf("%d %d",&n,&d);
  for(int i=1;i<=n;i++)
  {
    f[i]=i;
    vis[i]=0;
    scanf("%d %d",&x[i],&y[i]);
  }
  while(scanf("%c",&s)!=EOF)
  {
    if(s=='O')
    {
      int r;
      scanf("%d",&r);
      vis[r]=1;
      for(int i=1;i<=n;i++)
        if(i!=r&&vis[i]&&dist(i,r))
          merge(i,r);
    }
    if(s=='S')
    {
      int r,l;
      scanf("%d %d",&r,&l);
      int k1=getf(r);
      int k2=getf(l);
      if(k1==k2)
        printf("SUCCESS\n");
      else
        printf("FAIL\n");
    }
  }
  return 0;
}


相关文章
|
4月前
POJ—2236 Wireless Network
POJ—2236 Wireless Network
|
4月前
Arctic Network( POJ - 2349)
Arctic Network( POJ - 2349)
[POJ 1236] Network of Schools | Tarjan缩点
Description A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”).
129 0
[POJ 1236] Network of Schools | Tarjan缩点
|
网络协议 网络虚拟化
|
人工智能
A - Wireless Network
POJ-2236 Time Limit: 10000MS Memory Limit: 65536K Description An earthquake takes place in Southeast Asia.
1015 0