PKU 3624 Charm Bracelet

简介: 本文主要讲背包入门题

Charm Bracelet

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 26   Accepted Submission(s) : 16


Problem Description


Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from theN (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factorDi (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more thanM (1 ≤ M ≤ 12,880).


Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.



Input


* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers:Wi and Di



Output


* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints



Sample Input

 


   4 6

1 4

2 6

3 12

2 7

 


Sample Output

 


   23

 


Source

PKU

 

01背包入门题


#include<stdio.h>
#include<string.h>
int f[13333];
int wi[4444];
int di[4444];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int m,n;
    int i,j;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d%d",&wi[i],&di[i]);
        memset(f,0,sizeof(f));
        for(i=0;i<n;i++)
        {
            for(j=m;j>=wi[i];j--)
            {
                f[j]=max(f[j],f[j-wi[i]]+di[i]);
            }
        }
        printf("%d\n",f[m]);
    }
    return 0;
}
相关文章
|
索引
LeetCode 42 Trapping Rain Water
给定n个非负整数,每个非负整数表示一个宽度为1的柱子,计算下雨后能够捕获多少水.
60 0
LeetCode 42 Trapping Rain Water
LeetCode 407. Trapping Rain Water II
我们把最外面的四边当成四面墙,想象海水面不断的升高,首先会浸过墙面最低的格子,如果墙面最低格子的四周(出了在墙面的格子)有比它矮的格子,那么这就可以形成一个蓄水池,蓄水池的最高高度就是墙面最低的格子,于是我们计算这个蓄水池可以获得的蓄水量;然后这个蓄水池被添加到墙面中;继续在墙面中找最低的格子;
89 0
LeetCode 407. Trapping Rain Water II
|
人工智能
Educational Codeforces Round 98 (Rated for Div. 2)B-Toy Blocks
You are asked to watch your nephew who likes to play with toy blocks in a strange way. He has n boxes and the i-th box has ai blocks. His game consists of two steps: he chooses an arbitrary box i; he tries to move all blocks from the i-th box to other boxes.
254 0
PKU 3624 Charm Bracelet
本文主要讲背包入门题
HDU-1029,Ignatius and the Princess IV
HDU-1029,Ignatius and the Princess IV
|
Go
HDOJ/HDU 1087 Super Jumping! Jumping! Jumping!(经典DP~)
HDOJ/HDU 1087 Super Jumping! Jumping! Jumping!(经典DP~)
79 0