HDOJ-1004 Let the Balloon Rise

简介: Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Problem ...

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink

统计出现次数最多的字符串然后输出,用冒泡的方法将相同字符串出现的次数统计到一个数组,然后记住出现次数最多位置,将这个位置的字符串输出。

//AC: 15MS  1692K
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
    int N;
    while(scanf("%d",&N)!=EOF){
        char color[1005][20];
        int max=0,t=0,num[1005];
        if(N==0)
            break;
        for(int i=0;i<N;i++){
            scanf("%s",color[i]);
        }
        memset(num,0,sizeof(num));
        for(int i=1;i<N;i++)
            for(int j=0;j<i-1;j++)
                if(strcmp(color[i],color[j])==0)
                    num[i]++;
        for(int i=1;i<N;i++){
            if(max<num[i]){
                max=num[i];
                t=i;
            }
        }
        printf("%s\n",color[t]);
    }
    return 0;
}

开始还准备用map< string,int >来写,结果自己完全没理解map,满脑子骚操作。

目录
相关文章
|
4月前
|
Java
HDU-1004—Let the Balloon Rise
HDU-1004—Let the Balloon Rise
21 0
[USACO 2021.02 Feb]Problem 3. Clockwise Fence
[USACO 2021.02 Feb]Problem 3. Clockwise Fence
LeetCode 407. Trapping Rain Water II
我们把最外面的四边当成四面墙,想象海水面不断的升高,首先会浸过墙面最低的格子,如果墙面最低格子的四周(出了在墙面的格子)有比它矮的格子,那么这就可以形成一个蓄水池,蓄水池的最高高度就是墙面最低的格子,于是我们计算这个蓄水池可以获得的蓄水量;然后这个蓄水池被添加到墙面中;继续在墙面中找最低的格子;
89 0
LeetCode 407. Trapping Rain Water II
|
索引
LeetCode 42 Trapping Rain Water
给定n个非负整数,每个非负整数表示一个宽度为1的柱子,计算下雨后能够捕获多少水.
60 0
LeetCode 42 Trapping Rain Water
HDOJ 1004 Let the Balloon Rise
HDOJ 1004 Let the Balloon Rise
135 0
HDOJ 1004题 Let the Balloon Rise strcmp()函数
HDOJ 1004题 Let the Balloon Rise strcmp()函数
98 0
HDOJ 1008 Elevator
HDOJ 1008 Elevator
86 0