CF788A Functions again

简介: CF788A Functions again

题目描述

Something happened in Uzhlyandia again… There are riots on the streets… Famous Uzhlyandian superheroes Shean the Sheep and Stas the Giraffe were called in order to save the situation. Upon the arriving, they found that citizens are worried about maximum values of the Main Uzhlyandian Function f f , which is defined as follows:


In the above formula, 1<=l<r<=n must hold, where n n is the size of the Main Uzhlyandian Array a a , and ∣x∣ means absolute value of x . But the heroes skipped their math lessons in school, so they asked you for help. Help them calculate the maximum value of f among all possible values of l l and r r for the given array a .


输入输出格式

输入格式:

The first line contains single integer n ( 2<=n<=10^5) — the size of the array a.

The second line contains n integers a1, a2, …, an (-10^9 ≤ ai ≤ 10^9) — the array elements.


输出格式:

Print the only integer — the maximum value of f .


输入输出样例

输入样例#1:

5

1 4 2 3 1

输出样例#1:

3

输入样例#2:

4

1 5 4 7

输出样例#2:

6

说明

In the first sample case, the optimal value of f is reached on intervals [1,2] and [2,5] .


In the second case maximal value of f is reachable only on the whole array.

如果奇数位开始,那么奇数位必为正,偶数位必为负


反之,如果从偶数位开始,那么偶数位必为正,奇数位也必为负


只要分奇偶循环各自走一遍,求最大和就好了

#include <bits/stdc++.h>
using namespace std;
const int maxn = 2e6 + 5;
typedef long long ll;
int a[maxn], b[maxn];
ll find(int l, int r) {
  ll res = 0, ans = b[l];
  for (int i = l; i <= r; i++) {
    if (res < 0) res = 0;
    res += b[i];
    ans = max(ans, res);
  }
  return ans;
}
int main() {
  int n, m;
  scanf("%d", &n);
  for (int i = 1; i <= n; i++) {
    scanf("%d", &a[i]);
  }
  for (int i = 1; i <= n - 1; i++) {
    if (i & 1)b[i] = abs(a[i] - a[i + 1]);
    else b[i] -= abs(a[i] - a[i + 1]);
  }
  ll ans = 0;
  ans = max(ans, find(1, n - 1));
  for (int i = 1; i <= n - 1; i++) b[i] = -b[i];
  ans = max(ans, find(1, n - 1));
  printf("%lld\n", ans);
  return 0;
}
相关文章
|
6月前
No rule to make target ‘.xxxxxxxx‘, needed by ‘debug/xxxx.cpp‘. Stop.
No rule to make target ‘.xxxxxxxx‘, needed by ‘debug/xxxx.cpp‘. Stop.
OMP: Error #15: Initializing libiomp5md.dll, but found libiomp5md.dll already initialized.
OMP: Error #15: Initializing libiomp5md.dll, but found libiomp5md.dll already initialized.
|
TensorFlow 算法框架/工具 Python
成功解决File "frozen importlib._bootstrap", line 219, in _call_with_frames_removed ImportError: DLL lo
成功解决File "frozen importlib._bootstrap", line 219, in _call_with_frames_removed ImportError: DLL lo
成功解决File "frozen importlib._bootstrap", line 219, in _call_with_frames_removed ImportError: DLL lo
|
Ubuntu C语言
【ubuntu】2.c:(.text+0xd2): undefined reference to `pthread_create‘ collect2: error: ld returned
【ubuntu】2.c:(.text+0xd2): undefined reference to `pthread_create‘ collect2: error: ld returned
145 0
libs/spandsp/src/floating_fudge.h:40:20: error: implicit declaration of function ‘sin’ [-Werror=impl
libs/spandsp/src/floating_fudge.h:40:20: error: implicit declaration of function ‘sin’ [-Werror=impl
118 0
relocation R_X86_64_PC32 against symbol ff_pw_9 can not be used when making a shared object
relocation R_X86_64_PC32 against symbol ff_pw_9 can not be used when making a shared object
289 0
|
网络安全
Qt :qt.network.ssl: QSslSocket : cannot call unresolved function TLSv1_1_client
Qt :qt.network.ssl: QSslSocket : cannot call unresolved function TLSv1_1_client
244 0
Qt :qt.network.ssl: QSslSocket : cannot call unresolved function TLSv1_1_client
|
Ubuntu
Could not load dynamic library 'libcudnn.so.8'
Could not load dynamic library 'libcudnn.so.8'
924 0