最长连续递增子序列
分数 10
作者 DS课程组
单位 浙江大学
给定一个顺序存储的线性表,请设计一个算法查找该线性表中最长的连续递增子序列。例如,(1,9,2,5,7,3,4,6,8,0)中最长的递增子序列为(3,4,6,8)。
输入格式:
输入第1行给出正整数n(≤10
5
);第2行给出n个整数,其间以空格分隔。
输出格式:
在一行中输出第一次出现的最长连续递增子序列,数字之间用空格分隔,序列结尾不能有多余空格。
输入样例:
15
1 9 2 5 7 3 4 6 8 0 11 15 17 17 10
输出样例:
3 4 6 8
#include<algorithm>
#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include <iomanip>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#include<map>
using namespace std;
typedef long long ll;
const int mod = 1e9 + 7;
const int INF = 0x3f3f3f3f;
const int N = 1000010;
const int NN = 10010;
int main()
{
int n,i,j,left=0,right=0;
cin>>n;
int a[N];
for(i=0;i<n;i++)
cin>>a[i];
int x=0,y=0,t=0;
for(i=0;i<n;i++)
{
x++;
if(x>y)
{
y=x;
left=t;
right=i;
}
if(a[i]>=a[i+1])
{
x=0;
t=i+1;
}
}
for(i=left;i<=right;i++)
{
cout<<a[i];
if(i<right)
cout<<' ';
}
}