Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
Sample Input
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
Sample Output
1
0
2
998
import java.util.Scanner;
public class Test {
public static int[] father = new int[1005];
public static int Find(int x) {
//递归实现
if (x != father[x]) {
x = Find(father[x]);
}
/*非递归实现
while(x != father[x]) {
x = father[x];
}*/
return x;
}
public static void Combine(int a, int b) {
int fa = Find(a);
int fb = Find(b);
if(fa!=fb) {
father[fa] = fb;
}
}
public static void main(String[] args) {
int n,m;
int a,b;
int sum = 0;
Scanner sc = new Scanner(System.in);
while (sc.hasNext()) {
sum = 0;
n = sc.nextInt(); //城镇数
if (n == 0) {
break;
}
m = sc.nextInt(); //路的条数
//初始化城镇
for (int i = 1; i <= n; i++) {
father[i] = i;
}
for (int j = 0; j < m; j++) {
a = sc.nextInt();
b = sc.nextInt();
Combine(a, b);
}
//找出所有独立的集合
for (int i = 1; i <= n ; i++) {
if (father[i] == i) {
sum++;
}
}
//sum-1为还需的连通的路
System.out.println("sum:" + (sum-1));
}
sc.close();
}
}