A - Farey Sequence——(筛法求欧拉函数)

简介:
A - Farey Sequence
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10  6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

题目大意:

就是求一个F(n)的中元素的个数。


解题思路:

首先我们分析一下题目,我们一看就是关于欧拉函数的题,就是求<=b中与b互素的个数,但是我们别忘记还得加上phi(<n)的值,所以这个问题就是求欧拉函数的和的问题,然后我们如果用正常的做法也就是暴力做的话 会超时的(我试过了/笑cry),所以我们要找到更快速的方法 ——筛法,其实这个筛法就是跟素数筛差不多的,也算是又学了一个知识点

void Init()
{
    memset(phi, 0, sizeof(phi)) ;
    for(int i=2; i<MAXN; i++)
    {
        if(!phi[i])
        {
            for(int j=i; j<MAXN;j+=i )
            {
                if(!phi[j])
                    phi[j] = j ;
                phi[j] = phi[j]/i*(i-1) ;
            }
        }
    }
}

Code:

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
typedef long long LL;
const int MAXN = 1e6+5;

int phi[MAXN];
void Init()
{
    memset(phi, 0, sizeof(phi)) ;
    for(int i=2; i<MAXN; i++)
    {
        if(!phi[i])
        {
            for(int j=i; j<MAXN;j+=i )
            {
                if(!phi[j])
                    phi[j] = j ;
                phi[j] = phi[j]/i*(i-1) ;
            }
        }
    }
}
int main()
{
    Init();
    int m;
    while(cin>>m,m)
    {
        LL sum = 0;
        for(int i=2; i<=m; i++)
            sum += phi[i];
        cout<<sum<<endl;
    }
    return 0;
}


目录
相关文章
|
8月前
|
机器学习/深度学习
分解质因子+欧拉函数
分解质因子+欧拉函数
46 0
约数个数和欧拉函数
约数个数和欧拉函数
87 0
|
8月前
|
Python
【Python 百练成钢】高精度加法、阶乘计算、矩阵幂运算、矩阵面积交
【Python 百练成钢】高精度加法、阶乘计算、矩阵幂运算、矩阵面积交
|
8月前
|
存储 算法 Python
【Python 百练成钢】高精度加法、阶乘计算、矩阵幂运算、矩阵面积交(2)
【Python 百练成钢】高精度加法、阶乘计算、矩阵幂运算、矩阵面积交(2)
|
8月前
|
存储 算法 Python
【Python 百练成钢】高精度加法、阶乘计算、矩阵幂运算、矩阵面积交(1)
【Python 百练成钢】高精度加法、阶乘计算、矩阵幂运算、矩阵面积交(1)
|
8月前
|
算法 测试技术 C#
【数学】【数论】【最大公约数】1819. 序列中不同最大公约数的数目
【数学】【数论】【最大公约数】1819. 序列中不同最大公约数的数目
|
8月前
|
存储 测试技术 索引
每日一题——除自身以外数组的乘积
每日一题——除自身以外数组的乘积
华华教月月做数学 两种方法: (快速幂+快速乘) (__int128+快速幂)
华华教月月做数学 两种方法: (快速幂+快速乘) (__int128+快速幂)
69 0
|
机器学习/深度学习 算法
欧拉函数算法的实现
欧拉函数算法的实现
欧拉函数算法的实现