R7-7 cm2inch

简介: R7-7 cm2inch

Given foot and inch, the meter is (foot+inch/12)×0.3048.


What sould be the feet and inches for an input centimetre?


PS:One foot is 12 inches.


Input Format:

One integer in terms of cm.


Output Format:

One integer for the feet and another integer for the inches.


Sample Input:

170


Sample Output:

5 6


题解: 这个可以看成一个实数,可以看成两部分组成,整数部分由英尺组成,小数部分由英寸组成,我们要的是整数,所以n/30.48直接取整,小数部分带入公式即可

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int n = in.nextInt();
        int foot = (int)(n / 30.48);
        int inch = (int)((n / 30.48 - foot) * 12);
        System.out.println(foot + " " + inch);
    }
}
目录
相关文章
|
2月前
|
监控 数据可视化 项目管理
CM模式是什么?如何应用?
CM 模式(Construction Management)即建设管理模式,起源于20世纪60年代的美国,通过专业的建设管理团队在项目早期介入,优化设计方案,协调各方资源,有效提升项目质量和进度控制。该模式已广泛应用于各类建筑工程,并不断创新发展,适应数字化、绿色建筑及国际化需求。未来,CM模式将继续推动建筑行业的进步。
|
5月前
|
算法
CF 1561
【7月更文挑战第20天】
49 2
|
人工智能
CF628B
CF628B
69 0
|
人工智能 网络架构
CF 698A
CF 698A
75 0
|
人工智能
cf 220B(莫队)
cf 220B(莫队)
98 0
CF1000F One Occurrence(莫队)
CF1000F One Occurrence(莫队)
54 0
对 matplotlib.cm.RdYlBu() 的理解
对 matplotlib.cm.RdYlBu() 的理解
对 matplotlib.cm.RdYlBu() 的理解